Schlagwort-Archive: Bug

Thunderbird-Addon Sieve wieder zum laufen kriegen

Auch wenn viele Leute wohl auf ewig nur eine Webmail-Oberfläche zum E-Mail versenden nutzen werden, weil sie schlicht kein Desktop Programm kennen, bin ich froh Thunderbird zu nutzen. Auch wenn es wohl nicht mehr wirklich weiterentwickelt wird, ist es eine tolle Software mit vielen Erweiterungsmöglichkeiten.

Eine davon ist das Filter-Addon Sieve. Mit Sieve kann man seine Mails bei einem IMAP-Konto schon auf dem Server in Ordner verschieben, abweisen, weiterleiten und vieles mehr. Mit dem Addon lässt sich das ganze komfortabel aus Thunderbird heraus bewerkstelligen.

Leider habe ich vor einigen Wochen festgestellt, dass das Addon die aktuelle Konfiguration nicht mehr von Webserver laden konnte. Meine erste Vermutung war, dass die Serverkonfiguration sich einfach geändert hat. Doch ich stellte fest, dass es am Addon liegen musste — denn es funktionierte bei keinem einzigen Konto mehr.

Ein Blick auf den Bugtracker des offiziellen Repositories bestätigte meine Vermutung. Die Lösung war aber nicht weit entfernt. Mit der aktuellen Entwickler-Version 0.2.3 funktioniert es wieder perfekt. Diese muss man herunterladen und im Thunderbird manuell hinzufügen. Danach sollte wieder alles wie gewohnt funktionieren.

Download: Sieve Nightly Builds

„Ungültiges Erweiterungsupdate“ bei Joomla Update

Heute war es mal wieder Zeit, einige Komponenten bei diversen Joomla-Installationen auf den neuesten Stand zu bringen. Leider funktionierte das neue Ein-Klick-Update-Verfahren, das mit Joomla 1.6.x eingeführt wurde, bei mir nie. Jedes mal erschien der Fehler „Ungültiges Erweiterungsupdate„. Bisher bin ich dem Fehler nie groß nachgegangen, sondern dachte, dass er mit einem der kommenden Joomla Updates behoben wird, da es wohl wirklich zwischenzeitlich fehlerhaft implementiert war. Da Joomla zwischenzeitlich auch schon wieder mal ein Update spendiert bekam, habe ich es auf einen neuen Versuch ankommen lassen. Hat natürlich nicht funktioniert. Fast. 😉 Bei einer brandneuen Joomla 1.7.x Installation funktionierte es! Ein guter Grund, der Sache mal mit Hilfe von Google genauer nachzugehen…

Auf deutsch habe ich nichts zielführendes gefunden, aber bei einer Suche nach der englischen Fehlermeldung „Invalid extension update“ kam ich der Sache dann auf die Spur. Der Fehler liegt wohl an einer fehlerhaften Migration von Joomla 1.5.x auf 1.7.x mittels jUpgrade. Deswegen trat der Fehler auch bei der frischen Joomla Installation nicht auf.

Der Fehler ist schnell erklärt. Eine Datei, die den Update-Prozess steuert, wurde bei der Migration nicht korrekt ersetzt. Sie stimmt mit der aktuellen Datei aus der Full-Version nicht überein. Die Lösung gestaltet sich entsprechend einfach. Die momentan eingesetzte oder aktuelle Full-Version von Joomla herunterladen, und die fehlerhafte Datei mit der korrekten aus dem zip-Archiv ersetzen.

Es handelt sich um die Datei update.php im Verzeichnis /administrator/components/com_installer/models/. Diese Datei muss durch die aktuelle ersetzt werden.

Mit der aktuellen Version der Datei hat das Update im Bereich „Aktualisieren“ auf einmal wunderbar geklappt. 🙂

Joomla! 2.5 für Einsteiger (Galileo Computing) (Taschenbuch)
by Anja Ebersbach, Markus Glaser, Radovan Kubani

Price: EUR 0,97
7 used & new available from EUR 0,97
3.8 von 5 Sternen (10 customer reviews)

Joomla! 2.5: Professionelle Webentwicklung (Gebundene Ausgabe)
by David Jardin

Price: EUR 35,00
13 used & new available from EUR 0,60
4.4 von 5 Sternen (15 customer reviews)

 

Windows 7 Zwischenfazit

Jetzt habe ich seit einiger Zeit Windows 7 auf dem Laptop installiert (Uni ist toll :)) und denke, man kann mal ein kleines Zwischenfazit ziehen. Daher werde ich ein paar meiner Erfahrungen von dem was mir positiv und negativ aufgefallen ist mit euch teilen. Im Vergleich zu Vista ist mir als allererstes die veränderte Taskleiste aufgefallen. Das ist für mich im Grunde die größte Veränderung. Aber mit der Zeit gewöhnt man sich daran, und es ist hilft einem auch wenn man mal mehr als 3,4 Programme offen hat. Auch die kontextuellen Neuerungen (Dokumente anheften) finde ich ganz nett.

Auch sehr sinnvoll und vor allem für größere Monitore interessant ist das Andocken der Fenster, so kann man manchmal doch schneller arbeiten ohne vorher erst groß die Fenster in der Größe anzupassen, oder umständlich auf die alte Art und Weise nebeneinander anzuordnen. Wer nicht weiß was ich meine, der soll sich einfach mal die Werbung zu Windows 7 anschauen 😉

Neben den vielen positiven Sachen, die natürlich vor allem im Kleinen passiert sind, hab ich aber doch ein paar Kritikpunkte. Mein System ist mir schon einige Male abgestürzt (BSOD), das hatte ich vorher vielleicht einmal im halben Jahr. Mit Windows 7 ist mir das doch schon das ein oder andere Mal passiert. Und das ist ein frisches System, dass noch nicht zugemüllt ist. Speicher überprüfen, wie vorgeschlagen, hat nichts ergeben. Ich kann mir auch nicht vorstellen, dass meine Hardware beim Windows-Wechsel kaputt gegangen. Ob es an einem Treiber liegt? Ich glaube eigentlich nicht. Habe keine speziellen zusätzlichen installiert. Mal sehen ob sich das noch gibt. Man kann ja nie wissen. Ob ich einen Neustart versuchen sollte?

taskleiste bug
Symbole verschwinden spurlos ...

Außerdem hab ich noch ein komisches Verhalten der kleinen Symbole im Infobereich. Die Programme laufen, nur die Symbole verschwinden, es schaut aus als wäre nur noch ein Platzhalter da. Arbeiten kann man trotzdem noch, ihre Funktion haben sie also nicht eingebüßt. Im Netz habe ich dazu noch nichts gefunden, hat sonst noch jemand dieses Problem. Um es zu verdeutlichen habe ich mal einen Screenshot von meinem Problem gemacht. Ist kein Weltuntergang, aber es nervt leider trotzdem.